لينكس makefile للتحقق من الحد الأدنى المطلوب إصدار لينكس النواة

لدي makefile linux يحتاج إلى ترجمة على إصدارات مختلفة من kernel. لم يتم إنشاء makefile من automake/autoconf.

رمز C بالفعل مشروط باستخدام وحدات الماكرو لتوليد رمز مختلف لإصدار kernel مختلفة ، ولكن يجب أن تكون بعض الميزات في makefile أيضاً مشروطة.

هل هناك طريقة في makefile للقيام:

if (kernel_version > 2.6.30)
    newer_kernel = 1
else
    newer_kernel = 0
endif
0

لا توجد ردود.

0